Bootstrap Table generator behaving oddly

OS info

  • Operating System : Windows 10.0.19042
  • Wappler Version : 3.9.3

Problem description

When using the bootstrap table generator to generate a table from a paged query, I noticed two odd things. I haven’t used this in a while so it may be me, but wanted to report it just in case. I don’t think it’s relevant but the server model is PHP.

After selecting the query manager and clicking on the sort and dir parameters, I get a List Empty message.

If I generate the table and then try to “edit” it by running the bootstrap table generator (clicking on the Run button here:

or here:

or here:

the generator comes back empty, as shown below

Steps to reproduce

  1. Generate a table
  2. Try to define the dir and sort parameters from a query manager
  3. Try to re-edit the table by clicking on either “Run” button. (BTW, why is the button in three different places?)

Many thanks,


Have you supplied a data source so that the table can be populated?

Sorry, I misunderstood your application. I now see that you want to create a list with recurring rows. That is not what the Generator is used for. In other words, don’t use the Generator, if done properly, your example should work as is.


Hi Ben,
Thanks for your response.

I’m not sure what is the difference between a table and “a list with recurring rows”. I used the Generator to create my table and it worked fine. The rows in that table come from a paged query in an API. The API works and the table is populated.

The problems:

  1. When I tried to add the query manager parameters sort and dir when I created the table for the first time, I got a message saying “empty list”.
  2. If I try to edit that table using the “run” button, the modal comes blank.


The table listing the collection is made up of recurring or repeating rows. This table was not constructed using the Generator.

The table on the right contains the data. This table made use of the Generator.

Fixed in Wappler 3.9.5

This topic was automatically closed after 28 hours. New replies are no longer allowed.