Bootstrap 4 Table Generator usage troubles

OS info

  • Operating System : Mac OSX 17.6.0
  • Wappler Version : 1.1.2

Problem description

Steps to reproduce

  1. Create blank HTML page
  2. Add components H+Cont+Row+Column
  3. Add Bootstrap 4 Table Generator (works well)
  4. Use Table Generator to create table (works well)
  5. Use Data Binder to generate table with data from dB
  6. Table Head row displays but not the table body rows and cells

This worked for me the first couple of times but now it does not. Tried over ten times but cannot get the table body rows to display.

I’d send a video of this but your uploader has a size restriction of only 200K - recently changed?

Here’s the bug (10.5 KB)

Out max upload size is 200MB not KB, so usually that should be enough.

Do you have the page link somewhere online - as I presume you have selected just the wrong expression

Or state what you have selected as expressions

At this stage I would only be guessing and my guess is that the data source is not being populated for some reason.

First point of call is server side (Server Connect) database query and make sure that you have not applied any filters. Also make sure that you save your server side actions. The latter is usually part of the problems that I encounter.

Second point of call is client side (App Connect) , making sure that the Server Connect has received the contents from the query. This can be done by clicking anywhere in your document until you see the Insert Binding button. I usually go to Code view to do this.

When you click the Insert Binding button, you can navigate to the Server Connect and view its contents as in

Escape from the Data Binding Panel without inserting the value into your document. Let’s know how you get on and come back here with your discoveries.

1 Like

Randy, I just discovered your other post, which goes along the same lines as this post. This may offer conflicting advise and confusing the issue.

Perhaps it is best to close/remove this thread and continue with the other post.

I finally figured out why my table rows were not displaying. You have to be careful how you name the query’s condition parameter… I was including a hyphen to separate the filename’s prefix from the rest of the filename which prevented the query from pulling the records – thus preventing them from displaying.

For example: all my image filenames are prefixed with 3 letters and a ‘-’. E.g., ‘abs-filename.jpg’ where the ‘abs’ prefix is used to sort all the images in my images folder into categories (abs is short for abstract). So in my query I was using "SELECT * FROM gallery_items WHERE Description LIKE ‘abs-’ " — getting rid of the ‘-’ in the query statement allowed the rows to display.

So the short of it is I’m NOT a rocket scientist. :frowning_face:

Good news! We have all been there and done that :sunglasses:

Thank you my friend for your persistent help. Hopefully I’ll get to a point where I can reciprocate and be of some help to others starting out with Wappler.

Here’s a question (just out of curiosity):

What is the difference building a dynamic table using the table component where you have to remove all but one row from the template table, and then use the Make Repeat Children function to repeat the rows, and then touch each column to link the data with your dB’s columns & cells, then add columns that the template table didn’t, and then rename the headers… when the Bootstrap 4 Table Generator does all that with two clicks?

What is the difference between the two outcomes and why use one method rather the other?

Randy, I think you have already explained the difference, the Table Generator (and the Form Generator) makes things so much easier and, more importantly, quicker. Don’t you love it?

As a side note, I would not set the query filter (condition parameter) on the server side (Server Connect) but on the client side (App Connect) by using Data View which in turn is based on Server Connect To illustrate

Instead of Server Connect, the Data View data can then be used to populate the table.


Oooh - I didn’t know about Data Views! That makes a whole bunch of things way easier. Thanks!!