Available Actions and Properties are blank

I have a form that I had previously set up onSuccess actions. But when I open it now to add more actions there is nothing available. This is only happening on one project. The only difference between this project and the rest of them is this one is a SPA.

So I don’t think this is a bug. I think it’s project related but am lost on how to troubleshoot it.

I’ve had that very very often on v3… I just didn’t have the time or patience to work out what the consistency was with when it happened, which is part of why I type in almost all of my actions by hand.
(Much to Teodor’s disappointment :wink:)

Would love to know what the solution is! :slightly_smiling_face:

You mean that you don’t see any available actions on the left side of the dialog?
Is this form on the SPA content page or on the main page? If on the content page - is a main page linked to it?
What is the form code?
How does the first line of the content page code look like?

For me, when I select an existing action, I don’t see any properties below to be able to edit it.

Antony, please report your issue in a different bug report topic explaining all the details.

Well I think it is the same bug as Brad is reporting which is why I put it here!

If you think it is the same issue, then report all the details so it’s a proper bug report.
“It doesn’t work for me” is not a proper bug report and lacks details.

Thanks Teodor,

That is correct. Only thing that shows up in the left side is two modals that are part of the layout page.

Yes, it’s a content page. I assumed everything is linked as it used to work as I had previously added onSuccess actions. to it when it was first developed about six months ago.

<form id="formRegistration" method="post" is="dmx-serverconnect-form" action="dmxConnect/api/canfor/register.php" dmx-on:success="formRegistration.reset();btn1.disable(btn1.disabled);toastsConfirm.show({message: 'Thank you for registering. We will be in touch with you to confirm your appointment.', delay: 10000, title: 'Kopar Administration Ltd.', subtitle: 'Canfor Job Fair Registration'})">

<!-- Wappler include head-page="index.php" appconnect="local" is="dmx-app" bootstrap4="solar" fontawesome_5pro="local" jquery_slim_33="local" components="{dmxAnimateCSS:{},dmxSwiper:{},dmxValidator:{},dmxBootstrap4Toasts:{},dmxBootstrap4Alert:{}}"-->

Anything look out of place in the code?

Any ideas? I really need to add more actions to this form. @Teodor

The properties are usually blank when the component is not found in the app structure hierarchy. Maybe it was renamed or moved without changing the expressions.

So try recreating the page or the components

I just tested on a SPA content page and i can see all the components on the content page itself as well as the ones on the main page:

So there is no issue with this, probably something related to what George suggests.

Hmmmm, nothing was changed or renamed. Tried adding a new form to the page and it still doesn’t show up.

I have three content pages with forms and I have this problem on all three. The code I provided looks okay?

The problem might be that you are referring the same form.

Also for executing so many related actions, you might consider using a page flow.

Hmmm, all three forms, although they are on different pages, have the same ID. Is that what you mean?

Yeah, this site was done well before page flows were a thing. :wink:

Do you have any “include” files in your head-page “index.php”?

This caused me great problems and so I moved all the code that was in my four include files directly into the head-page. Now there are no include files and I can see all my actions and all my App Connect Bindings.

Maybe worth trying, if you have includes.

1 Like

Interesting. Yes, there is a couple includes on the index page. I will try your suggestion. Thank you!

BINGO!!!

Thanks Neil! That indeed was the case. I removed the include and it now works as it should!

I owe ya a beer!

1 Like