Autocomplete doesn't allow me to pick Text or Value Fields

I am wanting to use the Autocomplete feature. After making an Autocomplete field from an Input field, I can select the Data Source (1st screenshot) but when I go to select the Text or Value Fields then I just get a blank data picker (2nd screenshot). Please help as I have meeting with client this afternoon and told him about this wonderful feature!

I have already used this feature successfully on other pages, but only when it was first implemented into Wappler. I have tried the usual closing the file, restarting Wappler, double checking, starting again, etc.

I can get it to work if I create a totally blank page and adding the bare minimum to test.

So what is stopping working on a normal SPA page?

@UKRiggers, check your main SPA page header and ensure that the Autocomplete css and js is added there.

  <link rel="stylesheet" href="/dmxAppConnect/dmxAutocomplete/dmxAutocomplete.css">
  <script src="/dmxAppConnect/dmxAutocomplete/dmxAutocomplete.js" defer=""></script>

I would then recommend checking the content SPA page and make sure that the Autocomplete reference is in the the Wappler comment at the top.

Hi Scott, thanks for your help. Yes both CSS and JS are on the master page, also the reference is in the head of the include page.

I have been playing, I entered the Text and Value Fields manually. That didn’t work. I then closed the page, and restarted Wappler (just a habit), opened the page again, saved it, refreshed in the browser (Chrome) and autocomplete WORKED in the browser. BUT, if I go back into Wappler and use the data picker, I still get a blank view! Strange.

Did you do a ‘full’ quit/restart:

This might help.

Hi Tom, yes, I did a restart, quit, logout and quit, I even did a quit-brew-powernap-restart! No difference. As mentioned above, I have got it working in a browser, just not able to see the data picker in Wappler.

Weird, you should be able to see in the picker just the four fields under your query data.

Is this in SPA setup only? Could you try the same on a normal page?

Hi George, as mentioned above, I can set up a fresh blank html page, add in Container Row Column Form Text Input (as per screenshot) using the same Server Action as on my SPA page and it works and I can see the Data Bindings.