Argon 2 on NodeJS issue

Wappler Version : 4.4.3
Operating System : Mac Monterey (M1)
Server Model: NodeJS
Database Type: MySQL
Hosting Type: Local Docker

I was trying to test out Argon on an existing NodeJS project but am getting some errors when trying to use it.

Firstly, I tried to adjust the Security Provider to point to the Argon field and ticked the Use Password Hash Verify box. All seemingly set up for the login step.

When I run the SC for login I got a

/lib/x86_64-linux-gnu/ version `GLIBC_2.25' not found


So I thought, it may need the Debian 11 image applied to the target. I changed this in Project Settings and re-deployed. All came up but I now get:

Cannot find module 'argon2'\nRequire stack:\n- /opt/node_app/lib/auth/database.js

I have tried unticking/reticking the use password hash, restarting Wappler, changing projects, but I can’t get the Argon module to reinstall on the new Debian image - I’ve even used all the clean/update npm package options. I also created a new Security Provider to see if that would initiate it - no luck.

Please help…

Is the argon2 module included in the dependencies in your package.json?

It looks like installing it once, which showed in the Output terminal on the first Debian image, sets a flag to prevent it being installed again. Even if the image changes it doesn’t reinstall…

well you can add it at the end of the list, before the end } as:

"argon2": "^0.28.3"

and then run the node modules install from the toolbar.

I will investigate why it isn’t added automatically.

Thanks George :beers:

Hi George,
I can see this is set to be fixed but just found that a change to the Security Provider permissions removed the argon2 entry from package.json so I had to add it again. Just letting you know in case it needs to be considered separately in the fix.

This has been fixed in Wappler 4.4.4

A post was split to a new topic: Node Argon2 error glibc 2.25 not found