API Timeout needed

If some wrong API infos is passed then API Schema Editor hangs, even after 5 min. Maybe some API Timeout is needed. Forced / Restartet Wappler then again.

Hello Freddy,
Are you not able to quit this dialog by using the Esc button?

i tried to close it by mouse, didnt worked. Will try again with ESC,m tomorrow

Okay ESC worked

1 Like

Maybe some kind of error has occurred.

Could you restart Wappler with logging and send us the debug log after the error occurred.

Hi.
Is there any option to set TIMEOUT value for a server action API action?
I have an API which takes around 3 minutes to response. But Wappler returns an error in 1.7 minutes (100 seconds) max.

You can add a script timeout in the server action settings:

1 Like

Thanks for the quick reply. But, this does not seem to be saving.
It shows saved. But switching between server actions resets it to blank.

Well, is the value saved in your server action?

No. I checked the JSON with open in editor option, but it does not show any changes.
Running the API on browser timesout at 1.7m too.

When saving the server action, the value gets added on top your server action:

I am using ASP.NET.
I see a JSON file when editing the server action, and no such param entry for script timeout.

Not sure if that’s available for ASP.NET
@patrick will check this.

Maybe you can try setting this timeout is in your web.config
I think the default value of script timeout is 90 seconds there.

Tried using this:
<httpRuntime executionTimeout="180" />

Did not work.

Hello @sid

Did you try it on iis ?

And

  1. Open your IIS
  2. Go to " Sites " option.
  3. Mouse right click.
  4. Then open property " Manage Web Site ".
  5. Then click on " Advance Settings ".
  6. Expand section " Connection Limits ", here you can set your " connection time out "

Hi @s.alpaslan,
The link is for session timeout. I need to set the HTTP request timeout value.
The connection timeout settings for IIS is also ok. Its Wappler that is terminating the connection after 1.7m (100 seconds), so need a solution on Wappler’s end.
The API that I am calling works fine in Postman.

I event tried the IIS > Advance Settings > Connection Time Out… but it did not make a difference.

@patrick Can you please help?