Any Linux users?

Any resident Linux users around? Just wanted to ask if anyone here is using Wappler 4.2.2 on Linux? Thinking of returning back to Linux after running Windows for the past decade… Interested in feedback.

Replies appreciated as always!


yes I run Wappler on Chromebook / Linux … I think it runs better than Windows. It runs very stable


1 Like

Just go Mac @Dave , they have the M1 Pro and Max chips now, cummon, do it for those of us that cant afford the new chips so you can tell us how fast it is.

1 Like

Hahaha we considered going all in then updates were announced as we were about to purchase, waited for those updates, liking the new line-up and the return to a fat Mac! For a while it was like the Woke-Book rather than a Mac-Book! :smiley:

Really interested in returning to using Linux though. Going to run in to town and a grab a couple of SSD’s on the weekend and have a play about. Will consider a Mac over the next couple of weeks. Availability sort of dribbles down to Portugal, so may order via UK if we do make the leap. Least I know a good bloke to chat to for advice @psweb when it all goes Pete Tong hahahaha…


1 Like

Will be getting a new 16” MacBook Pro next week with M1 Max, so will keep you posted about the speed results :slight_smile:


If its amazing @George, I do have a spare kidney I am not using, so may just sell one and get an M1 Max instead.

@Dave, yup you know who to shout at if the Mac is poop, don’t worry I can tame any Mac, I even wrote my own kext once and it only took me 4 months to get it working, bahahaha.


All the best things in life are called Max


I sometimes used to run Wappler on Ubuntu Linux as a App of windows if i needed to have more than one copy of Wappler running alongside (for copying code across). Worked well. More and more of the Windows code seems to be integrating Linux subsytems

I used Black Magic Disk Speed Test
My Old Mac Book Pro - 500mbps read/write average
2020 Mac Mini M1 - 2400mbps write / 2800mbps read
2021 Mac Book Pro M1 Max - 5800mbps write / 5200mbps read

I think this is really where all that speed is mainly coming from besides processor.

1 Like

Hello, I’m run Wappler in Ubuntu 20.04, i believe the error are the same in all versions, overall it’s pretty stable.

1 Like

First post on the Community as a Linux user!

Not sure if anyone else has experienced all the issues with some of the latest Windows Updates? Weird, if I left the PC for a few minutes it totally froze… If YouTube was on in the background it didn’t, was too unstable to develop on… Anyhow it spurred us on to adopt Linux and to begin using it as our daily driver. So far happy with the fact that getting Wappler up and running literally took a couple of minutes, where as on Windows simply updating Wappler could take around ten minutes… All in all very happy right now. Running Ubuntu but considering Arch in the future? Input appreciated on that one.

Onward and upward!


I have dual boot with Linux Mint and Windows 11 with Wappler installed on each. From about a month usage developing project on both parallel, I can surely tell that Mint is giving way better experience with Wappler. On Win11 sometimes it is just hanging or too slow. Only downside on linux that the automatic update process doesn’t work, though it’s a matter of easy uninstall and reinstall procedure. As of Ubuntu vs Mint, Mint is far better as is now in my opinion.