Adding a filter to a table

Hi, I have generated a table, which went well, and have set about adding a filter.

I have created a FIlter variable in the Steps of the API Action.

That went well and the filter has been defined in the Query Builder.

On the App side the instructions are to use the Filter as a parameter to the Server Connect.


However, I do not get a place to add my Filter, only Sort and Dir. Neither of these parameters offer my filter variable for use.

How can I set my app to use the filter variable?


Could this be the problem?

Hi Ben, brilliant that worked, one little tick box somewhere eh.

Anyway, the filter now does filter the records properly but there is a problem

When I first start or refresh the web page to test this, there is, rightfully, no vertical scroll bar on the right side of the page. But when I type the first letter onto the Search text box, a vertical scroll bar appears the right side of the page, making the page jump a bit. The 2nd letter gets rid of the scroll bar, the 4th letter and the scroll bar comes back. The page is jumping with each letter you type. It is bizaar. I have checked the widths of all containers etc, there is nothing that I can find that is causing this.
The page is It is not protected yet.

Ben, I made a copy of the page and began to progressively strip elements out until the behavior stopped. I moved the Search Box to be outside the tabs and deleted the tabs (and my table) and then the behavior stopped. Does this give you a clue?. If I Undo in Wappler to bring the tabs back, the behavior resumes. The url to see this is

I suspect I have uncovered a bug.

For me the search bar isn’t doing anything at all there’s no scroll happening but also nothing filters?

It has something to do with the height of the body element. After the F1 I will come back and investigate further.

Please disregard my first comment regarding the body height.

Bootstrap rules must be followed. These are

However, your search bar and tabs are not within a container. Place a container around these sections or place them inside the container that houses the Activities.

Edit: Have a look at this video

Hi Ben, brilliant, I did have one thing not in a container properly, fixed that and now all is well, and the filters work. I wil check all my other pages for the same error. Thank you.

1 Like