500 - Internal server error on the SQL Database

I am not sure if anyone has encounter this error. I had to switch from a 2012 - 2018 ms web server recently. On the old server the database connection worked and the website worked great. Since switching over, I have tried to reconnect to the database but it keeps giving me a 500 error. What am I do wrong?

Are you getting the error in Wappler or in the browser? Try turning on Debug in your server connect settings.

The browser is fine. The charts are not working because it’s not connecting to any db. I am getting the error on Wappler database connection. Thank you in advance.


What error is being reported in the 500? In other words, what is the exact error?

That’s pretty much the exact error… 500 internal error… but after the update this morning… In the database connection, i click save and a prompt came up with “query the database” with the pinwheel. The prompt is up for a few minutes and the entire program shut down and i have to restart it again. ugh.

The 500 error will be reported with more detail if you turn on debugging.

Then check the browser console

The 500 error should also logged in your website error logs.


I am still having this issue… I narrowed it down to a connection string issue from the logs. I am not sure what to do. I think at this point, I tried everything. I need to get this project back on track.


Well, please check the exact error returned by your server action, as explained in the following tutorial:

The problem with that is there’s no errors when i go to XHR. The only error is from the software which says 500 error when i try to connect on wappler. I see this in the logs…

Make sure you followed the instructions that Teodor provided. The error is available in the browser once you follow those steps.

I thought I have been doing that… I didn’t have any problem on my old 2008 web server but I recently migrated to 2012 server and the system has been giving that error ever since. I have been reading through all of the post to see if I am missing anything and tried all of them and still having the issue.

Working through [Paul Strydom] (https://www.youtube.com/channel/UCD9qkbCgoF0Gtw-hMKK5rSQ)User login tutorial and got a 500 error. Then found this post, then turned on the debugging mode, and fixed it all by myself :blush: Yeah.

Nice one

1 Like