Wappler UI forgets selectbox and asks text input

Wappler 5.0.1
NodeJS + PostgreSQL
MacOS

Adding security restrict:

Provider is a text input instead of a selectbox

Also happened with Database Query steps, but it kind of happens randomly, I’m not able to consistently replicate. If I try to save the file (Ctrl/Cmd+S), then it becomes a selectbox and I’m able to pick one:

I believe you! #metoo
I wrote this 16 days ago: MacOS, Beta 8 or 9, MSSQL


i was using the default name ‘query’
and made some more API connections naming them different.

the very next one connected fine and showed data.
*but in the properties tab it didn’t show a pulldown for the Database Connection name. It was a text field I could enter text into, NOT a combo/pulldown.
Then it starting acting weird and I made another API connection…

I went back to latest V4 non-Beta and all worked as it should.


was very odd, and i couldn’t let it waste my time so had to retreat to v4.
being a newbie, it would be normal for anyone reading it to just dismiss me as someone not knowing anything, esp. when it says “pro educational license”

1 Like

Please if you find a pattern to recreate this let us know so that we can check what’s going wrong. Currently we are not really able to reproduce this.

It happens randomly with no pattern and It’s been reported by others.

To replicate, as it’s random in behaviour, you’d need to use Wappler and experience it

Doing that at least few hours per day, i was able to replicate it on version 4 a while back, but hasn’t really happened for me since we fixed it back then.

I had it once today and a lot yesterday.

Ver 4.9.0

It should have been fixed a while back - November 2021, with the release of Wappler 4.3.0 - but if it still happens in version 5, then we will have to check this again @George

1 Like

I’m on 4.9.0

I won’t be moving to 5.* Anytime soon.

I’ve learned to live with it

It happened to me on the v5 beta 8/9. FYI
MacOS
MSSQL NodeJS

Me too randomly. Just delete the step and redo and will disappear. Maybe happen also in 5.0 Ineed to check it.

I reported this a while ago and can confirm it continues into v5

1 Like