UPDATED: not yet solved! Very sluggish behavior of Wappler!

I dived deep into my Mac. Not only removed Wappler, but deep searched for all Wappler maps. I found a whole set in user/library/application settings. Renamed that folder too _old.
Then did a fresh install, logged in and had to add all my projects again, but at least now it seems to work again as it should. :slight_smile:

Wappler Version :2.1.4
Operating System : Mac OS Mojave

Expected behavior

What do you think should happen?

A smooth UI and responsive behavior when starting the app, navigate file manager and working in the code, design view and in the sidebar windows of app connect, styles and DOM.

Actual behavior

What actually happens?

Wappler takes a while to startup, show purchase for about 30 seconds and then shows my pro level and I can start using the program .
Then after every click there is a delay of a second before responding. None of this happens in other software running on my Mac (Mac Pro 12 Core, 64 GB mem, radeon RX 580 8 GB).

Changes in App connect windows do not reflect in code/design views. Remove strings in code, in design view they are still visible, even after a refresh.
Changes in project settings are visually not saved . Open settings again, saved settings are gone. Restart Wappler: settings are saved.

How to reproduce

It is there all the time!

I have not been working with Wappler for a while, due to other tasks. But I did update every week and started the program at least once a week to see the new additions.
I got a feeling this is happening since 2.1.3. but it might be earlier, like I said, I have not worked with it for a while.

But now it is very annoying and almost not workable!! Sorry to say, but I almost got my Dreamweaver experiences back with all its quirkinesses.
Icompletely removed Wappler and did fresh install. No joy. I still hope it is not Wappler, but something in my system, but then again, all my other software is running super smooth on my fast system.

Hi Hans,

We have improved auto cleanup function in the latest Wappler, but if you got a very old one, it is better indeed to do a clean install.


Hi George,
Sadly, it only works temporary . After an afternoon work, the program starts again acting slow, unresponsive.

Are you sure it is Wappler at all? Maybe you have some other background apps slowing down everything.

Try checking the cpu usage in the activity monitor.