Swiper settings not updating code

======== TEMPLATE BUG FORM ========

Wappler Version : 2.4.2
Operating System : Windows 10

Expected behavior

Selecting options in the Swiper Properties panels should make changes to the code

Actual behavior

Some options update the code, others don’t

How to reproduce

Create a new page and add a Swiper component with a few slides. Choose options such as the Speed or Slides per view. As these options are selected, the code is not updated, so of course choosing these settings has no effect. Some options work as expected and update the code immediately; other have no effect even after refreshing or closing/reopening the file.

I tried changing settings on an existing page with a Swiper component, where I had chosen a number of options without any trouble (a few weeks ago). Again, changing settings in the UI had no effect on this page.

chrome_debug.zip (788 Bytes)

Hi Tom,
We found the problem, it seems to happen with the properties which are text fields.
We are going to improve this in the next update.

1 Like

Great. Will the next update be next week?

Also, could this be related to the issue mentioned here by @Kattouf? Again, the UI controls are not updating the code as before. I can’t add or delete formatting options to the Medium Editor Buttons. It hasn’t been a problem before.

Yes, it is the same issue - i replied there as well :slight_smile:

That’s good - I didn’t see that. I wonder if the issue could affect other components in the same way.

Do you know if there might be an update before next week?

This has been fixed in Wappler 2.4.3


I’ve just started using the swiper and it’s excellent. However, if I change the values in the SLIDES VIEW section (Space Between, Per View and Per Group) it doesn’t store the value so I’m only ever seeing one image in the swiper. Is this a bug? Can you give me the code to manually enter so I can get it working?

Changing all the other values works fine, it’s just the SLIDES VIEW section that’s not working.

Hello @sitestreet
There is an issue with the properties which are using number inputs.
It will be fixed in the next update.

Thanks @Teodor. Can you give me the code that would be inserted so I can do it manually for now?

Good to see this fixed in v2.4.3. :slight_smile:

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.