Spaces added when pasting

======== TEMPLATE BUG FORM ========

Wappler Version : 2.1.7
Operating System : Mac 10.14.6

Expected behavior

What do you think should happen?

Copying a value (using command C) and then pasting that value into another field (using command v) should paste the value into the new field

Actual behavior

What actually happens?

When pasting values inside of other values, spaces are added to either side.

How to reproduce

  • Detail a step by step guide to reproduce the issue
  • A screenshot or short video indicating the problem
  • A copy of your code would help. Include: JS, HTML.
  • Test your steps on a clean page to see if you still have an issue

Copy/Paste – results shown in screenshots.

Setup two set value actions with text in each:


Select the value in the first action:

And paste the second action in the middle of existing string:


Hello @mebeingken, that is weird!
Have you tried to do the copy+pasting test in Notepad or any editor if it has the same behaviour?

Yep… Confirmed this is only in the wappler editor. I copy and paste all day in all sorts of other apps.

Well, now that you have mentioned it, I tried it on my own Wappler GUI and it indeed put spaces before and after the characters I have pasted.
I don’t know, maybe it is intentional.

Seems this is a standard behavior by the modern browsers these days. Chrome and Firefox have a bit smart logic and are trying to be smart in paste actions and add some spaces that usually you do need when pasting words.

As Wappler is based on Chrome we inherit this behavior.

See for more info:

Interesting… Really slows down the copy/paste/modify workflow, so I think they are improperly generalizing the use cases!

I see the reason, but it’s useless in the UI. Can this be switched off there?