Slideshow: transition not working properly


#1
  • The sliding (transition:slide.direction:left.duration:1000="") goes all directions and the duration has no effect.

  • The fading (transition:fade.duration:4000="") flickers in Chrome every time you click the left/right controls - the duration has no effect

http://webcrea.be/slideshow.html


#2

Thank you for the bug report. I’ve managed to fix it, will be in today’s Wappler update.


#3

I am on v1.8.2 and 3D Transitions is still not working in Slideshow.
In Transition Options, ‘Direction’ is automatically set to ‘Random’ and greyed out, it cannot be changed.

There is a javascript error notification, clicking it opens a window and it looks like it is trying to reference the 3DTransitions.js file but the first part of the file location (from file to the project folder name) is duplicated. So it cannot find the js file.

It was working fine in the previous versions until recently. I need this working again! Thank you.


#4

this is a different general UI bug with grayed out fields since the last update and it will be fixed in the next update.


#5

Thank you George.

I’ve downloaded the update (v1.9.0) and the direction box can now be changed e.g to ‘Left’, but the slideshow itself is still on ‘Random’.

The HTML has been changed to Left:

And I’ve uploaded the dmxSlideshow3DTransitions.js again.

But still slideshow is on Random.


#6

Please provide a link to your page where we can check what’s wrong.


#7

I am also having an issue with the slider: I unchecked "Use image resizer " and “Auto generate image titles” save the changes and after I but they both get back to checked.
Is it a bug or what?


#8

That’s not related to the original topic.
These settings are just per image(s) import, so every time you import images you need to set these up.


#9

Ok thank you Teodor, and sorry but I asked that question in "General discussion " last week and had no answer so I took a chance here :slight_smile:
In my case I use images from folder so that is why it is not working?


#10

I am not sure I understand what your issue is.
Just to clarify - every time you import images you need to set these settings (“Use image resizer” and “Auto generate image titles" ) in the UI.


#11

I do understand that but in my case I used the “Add images folder” so I did not import each image manually or individually. So I would have to import them separately in order to use the Uncheck generate image titles?


#12

I still don’t understand what the issue is.
Can you explain step by step what you did, what happened and what you expected to happen?


#13

1= I created a folder with 7 images into
2= Add slideshow component
3= Click on “Add images folder”

So all 7 images automatically imported from the folder.


#14

So what is the problem here?


#15

Well, like I said in my first message I can’t hide the image titles using check/uncheck the “Auto generate image titles”. It semm taht it does not work a a global setting for the slideshow.
See here all the images still have the image name in each slide:
https://vr-surlepouceinc.com/new1/

To make it short: I DON’T want the images titles.


#16

So you want to report that the checkbox options when importing images do not work?
We are going to check this.


#17

Yes this is what I mean :slight_smile:
And same issue with checkbox “Use image resizer”
Sorry if I was no that clear and thank you for your patience with me.


#18

For me it works fine.
But I never use ‘Image Resizer’ or ‘Auto Generate Image Titles’. I always have to uncheck it. I don’t know why Wappler always check on default.
But the slidetransitions are working correctly.
Only the fadetransition is flickering in Chrome and the Duration can not be fine-tuned
Maybe in next updates ?
Great work! :+1:

http://webcrea.be/slideshow2.html


#19

Hi @Webjack357
i just tested this and if the checkboxes are turned off, the slideshow does not run the resizer and does not add the titles automatically - everything works as expected.

Are you sure you did not forget to turn these option off, before importing your images?


#20

Hi Teodor

Yesterday I did try to import the images from folder with theses options to ff but did not work.
I tried again this morning and while the checkbox do come back to “ON” right after I import images (strange?) at least now the titles don’t show anymore.