Server Connect (now called Workflows?) "Open in browser" option missing (version 4)

I can’t seem to find the option to open a server connect in the browser to see if it’s working property.

Here is the tool bar options in 3.9.9:

But, 4.0 it’s:
Anyone else seeing this?

Maybe it’s been moved and I missed it. I see Server Connect is now called Workflows, too:

Just press F12 to open your Server Actions in the browser.

OK thanks for that info.
I did that and got a web page with this error:

I know how to turn debugging on, but it seems the gear button is disabled or something. Nothing happens when I click it.

Maybe try restarting Wappler?
I just tested the settings(gear) icon in Server Connect panel and it works fine.

Yea, restarted Wappler, and now it works. But, I’m getting the same message in the browser even with Debug Mode on.

Are you sure you enabled the debug option (toggle) in server connect settings?

I think so:

What server model are you using? Can you open the terminal and see if the config file is uploaded to the selected target when the debug is enabled?

It’s ASP.NET running on IIS locally.

Here’s what the terminal shows:

So do you see the config file uploaded once you enable debug in the settings?

I believe so. I turned it off and back on and now it shows:

Ok then the debug message should be enabled on the selected target :slight_smile:

It’s working now, at least it’s showing the debug page. I deleted the target folder and recreated it and then it started working. I think I had some remnant files/folders in there from a pervious project. Starting fresh seemed to solve the problem.

Now my debug page shows this:

It seems to have something to do with my target setup. I have a host set up in IIS on my local machine called ‘sandbox’ and it points to C:/inetpub/wwwroot/CAM/Wappler/sandbox
Then in my Project Settings I have the WEB section defined as:

When I click Test Connection, I get a successful message, so it’s happy with it at that point, but there is obviously a problem with the namespace with that setup.
If I take ‘northwind’ off both the Web Server URL and the Local Folder, it works. But, it’s dumping everything in the ‘sandbox’ folder so I can only have one sandbox project at a time. I was hoping to be able to have several ‘sandbox’ projects (sandbox/project1, sandbox/project2, etc) and not have to set up a host for every single one.
So my question is, is there some setting to get the namespace corrected and still have the url multiple levels deep?

Seems you don’t have the required Wappler files in your site bin folder

Try saving a server action to generate them

So you’re saying it should work?

I tried saving a server action and tried again, but still get the same error.

Here is a shot of the Bin folder:

Can we please get the button back? I use this all the time and having to remember F12 (or for newbies even finding out that F12 is an option) isn’t a good solution. Not sure why the decision was taken to remove this - opening the server action in the browser is super useful for figuring out what’s going wrong with a server action, or how the data is being output. Thanks.


I see this thread is marked “fixed-in-next-update” and that’s great, but wondering if it’s both issues, or just the “Open in browser” button is back.
Will it work to define a Web Server URL as: site/project?

Your topic is about the Open in Browser button, which after discussing with the team we decided to bring back in the UI

If you have other issues report them in different topics.


OK that’s great, thanks for confirming.

And thanks for the fix!

Excellent! Thanks for that.