Server API Connector - Inspector UI rendering problems

OS info

  • Operating System : Windows 10.0.18363
  • Wappler Version : 2.5.4

Problem description

Cannot see header and query fields anymore in the server actions panel. Refreshing or restarting doesn’t bring them back.

See screenshare:

Might have something to do with the JSON data field, since this only seems to happen when I have this field populated.

Changing data type to “auto” brings back the query and header fields.

Please restart Wappler with logging, reproduce the problem and attach the debug log. See:

Here is the bug report including restart with logging. (201.8 KB)

I suspect it has got something to do with the array that’s in the JSON data field, which is related to this question:

I think this might be related. When I run into this problem of the query/header fields not being available anymore, and I change the JSON data field input, it doesn’t seem to save it anymore. I have to delete the entire server action and start over again.

Another thing is that my JSON output (which I catch using is a bit odd, because of my probably misuse of arrays. Maybe that too is related to this problem.

See my screenshare for clarification:

Switching back and forth from data type “auto” to “JSON” produces seemingly random results in output in

When the data type is set to JSON, for something simple like this code:

  "client_id": "test",

Produces NULL as output in, as seen here:

While a few tries ago it produced this as output in

"{\n \"client_id\": \"test\",\n}\n"

I wish I could replicate this consistently, but there seems to be a lot of random things going wrong here.

Hi @George, I hope you can give a quick answer in terms of whether I’m making a (formatting) mistake here, or that it’s a bug on the Wappler side. This way I know if I need to stop looking for a solution until this is fixed on your side.

Hi Nevil,

There was indeed a small glitch on the UI rendering when you were switching from the different Data Types. We will fix it in the next update.

This shouldn’t effect the JSON data submission. But indeed the headers fields become inaccessible.

1 Like

This should be fixed now in Wappler 2.5.6

1 Like

Hi Teodor, yes thanks for the extra Wappler update! It still doesn’t solve the problem entirely, but I have tagged you in another topic for this.