Security Enforcer Issues - wrong PHP include path

I need help with this problem I am facing. So I realize that most of my app connect pages had the same App ID for my backend pages, so I when ahead and renamed them this was after I had already added security enforcer on these pages. Now all of a sudden I am get this blank white screen with the following line of code whenever I view the pages. But when I remove security enforcer the page come back normal Can Someone please tell me what has gone wrong here.

@psweb @Teodor @Hyperbytes

Can any of you help me with the above?

Hey Brad,

How about uploading the file…not an image, but the actual file…somebody will likely see how to fix.



This text will be hidden

Sorry, that won’t work…need the actual file uploaded to the thread, or copy/paste the contents between 3 back ticks on each side (before and after code)

Not sure I am understanding what you asking of me. Are you saying you need to see the whole source code?


Thanks! One sec, and you say put it between 3 back ticks?

If you are copying the source code into a post (as opposed to uploading the file) then yes…start with 3 back ticks, return, then the code, return, then 3 back ticks. It preserves all the formatting that way.


This text will be hidden

I’m being stupid…the error is pointing to a missing file

<?php include 'phpincludes/firstheader.php'; ?>

Is that file still there?

Yes I updated the link to that file and I still get that error when I try to browse the page. That link is just the nav menu.

I just tried on my side and was able to replicate your error. So I then removed the header includes and the page loads fine after that.

Yeah it did that for me as well when I removed the include files, but then on my end the security enforce stop doing it function. I am honestly thinking about building over all the pages because I have no clue as why this is happening after I renamed the App ID.

There is a small issue with the serverside includes when using paths relative to site root.
It will be fixed in the next update - for now just change the links to relative to document and save your page.

Thanks Teodor!
So I should resave each each include files? Or should I change this in the project setting from Site Root to Document? Thanks again.

Open the project settings and change links to document relative.
Then just save the page with the issue.

This should be now fixed in Wappler 2.5.6 - please update and set your links back to site relative, the include file will have a correct path now.