Screen just goes black

Mac OS
Wappler 3.3.0

Problem:
When working on a file the screen just goes black with a white line.

The file I am working on does have a video background.
It is showing no errors on the page

Have to force quit Wappler and reopen.

1 Like

Happened to me twice today. The white block was different but the effect was the same. No videos or even images on my dashboard pages.

@brad I’ve currently got App Connect Switch off and it does not seem to be doing it (yet) possibly it may be a problem in there. Glad I’m not the only one having the issue.

Yeah, I haven’t reported because I can’t replicate it and don’t see a pattern as to when it happens yet.

No defiantly no pattern, it’s as random as my wife after a few wines

1 Like

Is it just this specific page because of the background video?

Any other pages are all ok?

And other pages with just video?

What is the exact MacOS version?

Mac version is 10.15.6 (19G2021)
It can happen at any time (its very random), there is nothing that I’ve done the same each time it has happened so there is defiantly no pattern.
Its happening on pages without video as well.

Does the whole Wappler app goed black and you see no UI or just the design view?

Any patterns when this happens and how often? Maybe it happens after a specific action or file open?

As the image above @George the whole thing goes black and there is a white line or a box will be white.
Cant see the design or UI in anyway.

Whole screen goes black. No UI at all. Not sure what triggers it. I had it happen where I was doing nothing at all. I had Wappler going on my MacBook and browsing Wappler forums in the browser on a seperate monitor and it went black. Wasn’t even doing anything in Wappler.

Unfortunately this seems to be a general Chrome bug that other regular web browser users experience as well:

https://support.google.com/chrome/thread/32109491?hl=en

If you were on a PC - I would say update your video drivers - as it is related to the Video card and GPU support, but on the Mac there is a little choice but to wait for an update from Apple.

If this happens really often, you can completely switch off the GPU usage of Wappler, but that will degree a little but your video performance.

To switch of the GPU in Wappler, you need to add an extra parameter to the Wappler startup:

On a Mac that will be:

  1. Quit Wappler completely from the tray, right click quit
  2. Start the Terminal and type:
    open -a "Wappler.app" --args --disable-gpu

Maybe you can make a shortcut for this.

Here’s George’s command with the curly quotes which break the command:

open -a "Wappler.app" --args –disable-gpu
1 Like

Corrected should be:

open -a "Wappler.app" --args --disable-gpu

Tried this @George still had an issue.
On thing I did notice is if you leave it a few moments then take it out of full screen then it shows back up again, this time I noticed it the Output that nothing was showing except an upset face (see image)

Not sure if this has anything to do with it, or if it is something else, but it is a bit of a pain.

This is a very different issue. Your web page just crashed in the browser. Might be a problem with your page. If it isn’t resolved with a simple design view refresh - file a new issue.

Tried this on Beta 13 and get a black screen.
I’ve rolled back to beta 12 and no issues.

UPDATE
Uninstalled and reinstalled Beta 13 and now its working for the time being.