Refresh database from within Database Insert/Update is not showing-up newly added database field

refresh database from within Database Insert/Update is not showing-up newly added database field. I do have to go to the DatabaseConnection and save it again to get the new fields.

Please restart Wappler with logging, reproduce the problem and attach the debug log. See: (4.7 KB)

That is still not working.

Hi, so you mean if you create a new field in the database it does not show up in the Wappler UI?

Thank you

Excatly. It doesn’t apprea in the Database insert/update panel even if I refresh the database from there. I have to switch to the connection step and refresh it.

Did you try hitting this button?
It should be working.

Thank you!

yes that’s why I started the thread ;-). It has been fixed in 2.5.1 but came back in 2.5.2

Yes because I had the same issue but remember that it was fixed.
Can you please also check the target? Sometimes updating on the local or viceversa and updating the remote target might cause this issue

Target is correct.

(1) If you alter the database (add field through PHPmyAdmin for example)
(2) Save connection (Wappler)
(3) Hit the refresh button as shown on the above screenshot it should work (Wappler)

Thank you!

PS Which is your initial post anyway :slight_smile:

I had a similar problem.
My workaround is to open the query.
Change the table used.
It will reload datastructure but destroy your query at the same time…
So don’t save : hit cancel.
Open the query again and now you can see your new field in the list of fields you can add for your table.
Might save you a few extra scrolls / clicks.

1 Like

This should be all solved in the latest Wappler updates.

Hi George. I still had it this morning but seems to be fixed later. Maybe I had some older files running.

It would be good to have a manual update button to let Wappler update all used files in a project.

This topic was automatically closed after 6 days. New replies are no longer allowed.