Redirect on success does not redirect

I have a regular insert form with a page redirect on success. The form submits but the page doesn’t redirect.

Please check again if the browser component is linked somewhere inside the page. It happened to me too and it was because of this. Although you most propably have the browser plugin linked just check to make sure

Hey Brad, have you included the browser component on your page?

Yes it is on the page. I will try removing it and readding it.

33%20PM

Removing it and readding it did nothing … it is definately on the page.

Is it uploaded? You on a local or remote?

Yes it's uploaded. It works on a page I added a couple weeks ago. Just will not work on this page.

Any misspellings maybe while calling ‘browser1’ ? Bet you checked them just trying to guess. Most propably it is a minor detail that is breaking it. Also try to reopen the file. The last update has some issues when adding new components. Although it shows everything ok in the UI code is broken or the opposite. Had some serious issues with this today. Functionality that was already added had to be reapplied. I mean I had to reopen the file and reapply any functionality

I can set an alert on success no problem. Is there a way to refresh the page on success? MAybe I can try that.

I have had issues like this when using dynamic parameters in the browser component. In the section ?profile=8109, is the 8109 produced by a dynamic value or static?

The 8109 is dynamic …

Do you get any JS errors shown in the browser developer console?

Nope, just the error shown in the original post.

OK, going to have to rack my brain to recall how i resolved this, i have had the same problem before but can’t off the top of my head remember how i resolved it, i just seem to recall it was linked to the dynamic parameter.

Have you tried changing the browser.goto to a static version of the parameter and see if the error still occurs?

You may be on to something. Removing the dynamic value it works fine. Unfortunately I need the dynamic value as it redirects to a detail page.

I will did through old code and see if i can find it. I am sorry but i just can’t recall how i got around it off the top of my head.
Just out of interest, how are you forming the link, i assume ‘employerProfile.php?profile=’+dynamic.value.here

That is correct. Actually the single quotes are outside the parameter as well.

‘employerProfile.php?profile={{query.employer}}'

Try the format i used above, i know that works as i have just checked an old video i made

(no need for curly braces)

Thanks @Hyperbytes! That worked! YOu have made my day.

1 Like

Wappler is still 99% magic and 1% voodoo!

2 Likes