Problem setting up "Sending Form Data to Email"

#1

Hi All, I am trying to create a simple form to send data by email. I am getting 400 Error and 405 Error. Can you please take a look at
https://daviesandgray.co.uk/bookings3.php
It contains a form with reCaptcha and Dropzone.

Errors…
HTTP method GET is not supported by this URL : Error 405
and
400 Bad Request : “recaptcha”: “Recaptcha check failed.”

I am sure I have forgotten to do something.

Here are some screenshots of the Wappler stuff :smile:

image

Cheers
Neil

#2

Hello,
I only see this error when i don’t click the “I’m not a robot” checkbox in recaptcha. If i click it, the form submits without an error.

#3

Hi @Teodor, thanks for trying the form. Your submissions came through OK.

Every time I tried I got no result. I tried about 6 times since your submissions and finally, the last one worked. I really don’t know why I was having issues and I didn’t change anything from before you tried. Anyway, I know it will work. I will do more testing to make sure all is OK.

The only thing I can think of is that something has happened with the clients hosting server, I will contact the hosting company to try to resolve. Thanks.

#4

Hi @Teodor, I am still having issues and it seems to be something to do with DropZone.

When I submit WITH an image selected, the form is NOT submitted and I get this error

image

When I submit WITHOUT an image selected, the form IS submitted successfully and I get this error

image

Any thoughts? I am confused.

#5

The server action, which i see when selecting an image is some validation error, related to file sizes:

Please attach a screenshot of what validation rule is applied and where.

Also make sure to check exactly the XHR tab and select the server action to see its response - just as on my screenshot. Do not check the console itself for such kind of errors.

1 Like
#6

#7

Please try removing the validation and see if it will fix the issue when an image is selected.
As per the other error in the console (when no image is selected) @patrick will fix it, it’s not a fatal error and won’t stop your form from working.

1 Like
#8

I struggled with this for a while. I didn’t realise at first that the Validation Rules were under both the App Structure > Dropzone > Properties and the Server Actions > Action Steps > images > Properties.

I deleted the Validation Rules from the App Structure side but I was still getting the error. I looked at the files in the \dmxConnect\api\ directory and saw that the validation rules was still there. I then went into the Action Steps and removed the Validation Rules from there.

This has stopped the errors and allows the form to be sent BUT no images come through to the email addresses.

#9

Well, did you add the attachments to the email step at all?

#10

Ahhh! Hmmm?

At a guess, I should have added $_POST.images something like this…

Is that all that I should do?

#11

No, you need to get the paths of the uploaded image from the upload step.
You cannot just get a file info from the POST vars.

1 Like
#12

I hate to say it but I’m failing miserably. I am trying to resolve this myself but getting nowhere.

I have added a File Upload step and when I fill in the form and send it, the files are uploaded to the temp folder but they are not sent with the email. So I am getting closer. I have tried various things but nothings works. Can you give me a clue? Or better still, tell me what to do :smile:

#13

What expression are you using in the send mail step for the attachment?

#14

/web_upload/temp_email_images/{{upload1}}

#15

No, I don’t need the upload step path.
What is selected for the attachment in the send mail step?

#16

Haha, that’s what I’ve got! Obviously wrong then :frowning_face:

#17

You need to get the file url from the upload step.

#18

Really struggling with this one @Teodor I thought that was what I had with /web_upload/temp_email_images/{{upload1}}

#19

The file upload step returns the url to your uploaded file. Just select it in the data picker…

#20

So, just simply this?