PostgreSQL Database


#1

Hallo Wappler Team

We work normaly with MySQL Database and we ar happy wit the Server / App Connect. But now we have e Project with PostgreSQL.
http://planland.ch/ibnl/wappler
Its a simple test site with dynamic content. We tried it on different servers and hostings, always the same problem with the database actions.

We can make a Database Connection. We can make a Query and Server Connect, but then we get no Results on the Site:

Failed to load resource: the server responded with a status of 500 (Internal Server Error)
on the generated File http://planland.ch/ibnl/wappler/dmxConnect/api/content.php

{
“code”: “42601”,
“file”: “/var/www/html/ibnl/wappler/dmxConnectLib/lib/db/Connection.php”,
“line”: 82,
“message”: "SQLSTATE[42601]: Syntax error: 7 ERROR: syntax error at or near “\"\nLINE 1: SELECTb_organisationFROMbenutzer\n ^", "trace": "#0 /var/www/html/ibnl/wappler/dmxConnectLib/lib/db/Connection.php(82): PDOStatement->execute()\n#1 /var/www/html/ibnl/wappler/dmxConnectLib/modules/dbconnector.php(67): lib\\db\\Connection->execute('SELECTb_organ…’, Array)\n#2 /var/www/html/ibnl/wappler/dmxConnectLib/lib/App.php(159): modules\dbconnector->select(Object(stdClass), ‘content’)\n#3 /var/www/html/ibnl/wappler/dmxConnectLib/lib/App.php(128): lib\App->execSteps(Object(stdClass))\n#4 /var/www/html/ibnl/wappler/dmxConnectLib/lib/App.php(98): lib\App->execSteps(Array)\n#5 /var/www/html/ibnl/wappler/dmxConnectLib/lib/App.php(71): lib\App->exec(Object(stdClass))\n#6 /var/www/html/ibnl/wappler/dmxConnect/api/content.php(8): lib\App->define(Object(stdClass))\n#7 {main}”
}

We could not found a bug. Thanks for your instructions.

Freundlich grüsst Sie
Daniel Zobrist


#2

Hoi Daniel, probier emolle bi dim Select Statement wo „Where Benutzer“ evtl es Afiehrigszeiche z‘ändere. Cha si, dass wege dem dr 500er Fähler bechunnsch. Oder eifach mol s Select statement z‘minimalisiere als Test. zb:

Select * from benutzer;


#3

Danke für d Info, aber das nütz beides nüt, o weni alli " ersetze.


#4

@patrick will investigate the error you got.


#5

Hello George
Thanks.
Please investigate the error because i can not go on without your solution.
All database actions, insert, update, query … make errors in the generated files from wappler.