Missing system files on remote server (404)

I cannot understand if it is an error or not. I can’t avoid these errors
Schermata 2021-10-12 alle 22.26.07


Evidently it does not read the files that are missing, even if the files seem to still be present in the public / dmxAppConnect folder
Anyone know how I can go about solving this problem?

I’ve never clicked the Deploy button so I don’t know exactly what it does, but can’t you just manually upload any missing files - using Wappler or an FTP program?

Deploy I have run it several times but the problem does not change
For this site I don’t use ftp, because it’s in Nodejs
And in any case, using the terminal it turns out that the files are present on the server

Sorry - I didn’t realise this was using Node. The paths look odd with the # symbol. Perhaps that’s because of the line-wrapping. It must be frustrating not to be able to fix what should be such a simple problem. Hopefully someone more familiar with NodeJS will be able to help.

Thanks anyway
I hope @Teodor reads this and can answer me
I also thought about the fact that the project is set up with links relative to Document and maybe it would be better to root
But it is not explained why all the other files are read regularly.
Also I think if I replace the root link I risk messing up the whole project

Unfortunately I don’t see any answers and I am quite confused, because despite the reading errors of some system files, several actions still work correctly.
I do not know at this point if the origin of my troubles is to be found in the difficulty of reading the system files, or for another reason, but now a simple action of deleting a record does not work for me.
To search for the source of the malfunction, I created a simple record deletion action (without for the moment inserting the folder and file deletion steps)
First of all, testing with “Open in Browser” I get a result that I can’t decipher.
In a records list table, I have a column with button to invoke the delete record action.
The code seems correct to me, but it doesn’t work because the record is not deleted
I have an urgent need to resolve this
Anyone know how to fix?

This is the action

This the “Open in Browser” result
Schermata 2021-10-14 alle 15.32.16

This the Button code list record page
Schermata 2021-10-14 alle 15.36.01

you are using {{$_POST.idprodotto}} in the delete action, while your field id is del_prodotto … that’s why no file is deleted.

I changed it like this but it still doesn’t delete the record
Schermata 2021-10-14 alle 16.37.58

Give your input and id of inp_idprodotto and create the same POST variable under POST in your server action. Then use it in the delete record.

Sorry but I didn’t understand very well, also because this action has always worked on sites, but now maybe for nodejs there is something different
Should I set it up like this?

Schermata 2021-10-14 alle 16.56.42

No marzio, nothing is different for nodejs …
Just make sure now you have a post variable created named inp_idprodotto and use it in the delete action!

I have changed the action but not work

So are you sure the hidden field gets a value actually? Can you see its value by inspecting it with the dev tools?
Are there any errors in the network > XHR in the dev tools?

This is without the hidden
Schermata 2021-10-14 alle 17.13.25

When I click the button …

So the prodotto_delete runs fine (status 200 = OK)? And it sends the value to the server?
What is not working for you then?

In fact it does not give an error, but the record is not deleted from the database and I also check it with Navicat

Is it normal that the action gives this result?
Schermata 2021-10-14 alle 15.32.16

Select the server action in the XHR tab and see if there are any messages:

Switch to headers tab and check what values does it send?

This message
Schermata 2021-10-14 alle 17.28.45