Map path error in mailer after update 3.5.x (ASP Classic)

I’m not sure what version of the update broke my mailer but it was probably 3.5.x. I had a similar issue with my database connections that @teodor fixed right away and wondering if this is the same kind of issue?

in the lib/mail/mailer.asp file

"006~ASP 0174~Invalid Path Character(s)~An invalid ‘/’ or ‘’ was found in the Path parameter for the MapPath method.

I’m now currently on 3.5.4. I deleted the mail.asp and also the mailer.asp files and it recreated them and made sure I uploaded them to the server.

I have the same error!! I just posted an update to the original post last week.

Mine is happening on all my Classic asp connections for this site.
Adding @patrick to see if anything can be done.

Please test following update, unzip in dmxConnectLib/lib/db.

connection.zip (1.5 KB)

1 Like

Awesome @patrick . I updated the file and will keep an eye on it. So I have to ask, why was it only giving an error sometimes? It’s the crazies thing I’ve ever seen.

I’m still getting same error

here is a test page.

https://testing.hitekfab.com/emailtest.asp

Got the same error. Al of my forms that send an email after insert data have an issue. I have all config to send html emails … when i turn it to send static emails it’s ok. Probably that’s something related to this…

not sure. My test page is super basic with the mailer and is using static and not html

Did you got all updates from here:

They will also be included in the next Wappler update.

2 Likes

not sure that I got all those updates. I’ll download them all now and try again.

Thanks

Thank you!, Thank you!, Thank you!. It fixed all my issues. Another motivator for me to convert these older sites to .NET.

That did the trick! Thanks again @George

@George. One lingering issue. My old mailers work now, but if I create a new one it does not, I get the following error.

{“type”:“Error”,“fileName”:“lib/mail/mailer.asp”,“lineNumber”:41,“errorNumber”:-2147220960,“message”:“The “SendUsing” configuration value is invalid.\r\n”,“stack”:[{“fileName”:“lib/mail/mailer.asp”,“lineNumber”:41,“method”:“send”,“args”:

Have you setup host and port correctly?

Yes, using the same connector from a previous action works fine.

What are the settings used?

You want the specific Setup Mailer Properties?

Do you want the specific settings for the Mailer?