Linux: No Design Panel Options

Wappler Version : 2.3.3
Operating System : Linux

Expected behavior

Selecting a BS4 component on App Structure and switching to the Design Panel should give design options after creating a class.

Actual behavior

New class is created but there are not any design options below.

How to reproduce

  • Create a new project
  • Add a css file
  • Attach css file in Design Panel
  • Create new button in App Structure
  • Click to select
  • Change to Design Panel
  • Create new class “button”
  • No Options within Design Panel

I was hopeful that version 2.3.4 was going to solve the problem but unfortunately it’s still not showing me any options in the Design Panel :frowning:

Please restart Wappler with logging, reproduce the problem and attach the debug log. See:

Sure. Can you tell me how to start logging on Linux?

is the same - just right click on the small wappler icon in your top bar on Linux and choose the restart with logging option there.

I don’t have a desktop environment since I have Linux running on ChromeOS so no GUI with top bar.

Hmm could you share a screenshot of your desktop? How are you launching Wappler?

and in the meantime if you get this issue, could you just try to select a different component and then come back to the current one? See if you then get the design panel fully.

That didn’t make a difference.

thanks - I think we found the problem. Will improve it in the next update.

For now maybe just save the file first and then apply the class and reselect.

1 Like

Sorry, I should have been more specific. I don’t have one of the standard Linux desktop environments (i.e. Gnome). I am able to launch Linux apps from the ChromeOS desktop environment but it doesn’t give me the top menu and usual right click icon options I would have in a regular Ubuntu distribution.

I am able to start Wappler from the Wappler icon in the ChromeOS launcher or from the shelf (dock) but again I don’t have all the same right click options that I would have in a traditional Linux distribution.

There is a side menu that has some of the functionality of the top menu such as notifications. This is where I get prompts to update Wappler, but that’s about it.

Thanks for continuing to troubleshoot this @George!

That didn’t fix it either.

Check if this is solved now in the latest Wappler 2.3.5

1 Like

2 posts were split to a new topic: Add check for updates and other tray icon menu options to the main menu

It’s still not fixed.

Is it only the case you described above now working or is design panel always empty with you no matter what files you open?

The design panel is always empty for me. When I create a new class, it is inserted into the designated css file but I don’t have any visual way to add attributes. I can only create new classes.

Hmm will do some more Linux testing then.