LFTP and NodeJS could not detect version

When I run the “System check” in Wappler I get these results.
What does it mean and what should I do?

LFTP could not detect version!
NodeJS could not detect version!


1 Like

What OS do you have and did you try to restart Wappler fully? Is this a new installation?

Windows 10.
This is not a new install.

I restarted fully. Even ran updates.

It started when I changed/moved the directory on my computer for one of my wappler projects.

i have the same issue and i even uninstalled Node.js and wappler and reinstalled them and still not working!

1 Like

New install for me and im also having the same issue with a whole heap of really unexpected behaviour which could just be because i dont know that im doing. Im just getting NodeJs issues however not LFPT aswell.

just installed wappler last night. Installed Node this morning.

Node is installed.

An update, if you create a new project and select wappler server and node.js, you won’t get the error. Atleast I didn’t. If i open a project i’ve already started, that isn’t a nodejs project… i’ll get the error and that makes absoluely no sense.

1 Like

any update? i cant also deploy my latest changes, because of the error.

Found the problem. It was just the system check version check on Windows that was broken in the last updates.

It was just the system check, normal running, publishing and file upload should all work fine.

Anyway the system check will fixed in the next update



I just wanna know if there is an alternative solution for now? i cant even deploy my latest changes to heroku,

1 Like

This has been fixed in Wappler 4.8.3


This topic was automatically closed after 2 days. New replies are no longer allowed.