I can't select tables from another db schema (MS SQL) in NodeJS

Hi,

as I wrote in the title I can’t select tables from another db schema anymore. I recreated my API in NodeJS and created new database connections with the new db manager. My new connection to our MS SQL server only connects to the standard dbo schema.
The “old” db connection prior Wappler 3.0 was able to read additional schemas.
Any idea how i can solve this?

Thanks for your help in advance :slight_smile:

Marcel

Good one - we will add a schema name option to the database connection settings for MS SQL

2 Likes

Hi @George, thank you for adding the db schema for selecting tables in queries.

Is it also planned to have the functionality in db manager? I only see the tables from the dbo schema (MS SQL) in db manager.

EDIT: I only tested in PHP. Selecting tables from another schema is still not working in NodeJS. At the moment I have a workaround with custom queries with copy & paste from Navicat, but it would be great if it could be changed after your vacation :slight_smile:

Any news on this? It is still not working in NodeJS.

Just to be clear you mean you want to see the tables from other owners than dbo?

Or the tables from different databases on the same server?

@George

Yes :grinning: