Dynamic Table Repeat Children usage troubles


re: Macbook Pro Retina 15", OS X v10.13.5

I downloaded Wappler v1.1.2 and have had several screen freezes as I worked:

  • Created a dynamic table
  • Make Repeat Children
  • Added expressions
  • Changed from ‘Body’ to ‘Page’ to make the rows & cells visible
  • App froze, I had to force quit and start all over

Here is the bug report for you to review:
report_2018-6-6_20-1-13.zip (513.4 KB)
(Let me know if you want a video of this happening)

Hi Randy,

Well this is an achievement! It is really difficult to get Wappler freezing these days! So well done! :slight_smile:

Why should you do that? changing the App Connect rendering from body to the whole page? This changes the working of the rendering of your page so that includes also the html head and is definately not a refresh procedure.

If you just want to refresh design view to see the rendering (usually this happens automatically) but if for some reason it doesn’t - just hit the design view refresh button.


Also we changed a bit the procedure for the debug log generation, so check out the new one:

Also a tried to reproduce your steps, even the one with the weird way to refresh, but Wappler never crashes or freezes for me.

Maybe you can try to reproduce it your self a few times and if possible shoot a short video.

Crashes also usually happen of older and somehow maybe corrupted installation of Wappler. You can try to do a clean install:

Did the complete reinstall and tried again to create a dynamic data table. The head displays all the correct fields but the table body rows do not display nor repeat after I select Make Children Repeat and add the Expression from the Data Bindings. Tried this in a different project and got only the first row to display - could not get the table body to repeat rows with all the records. See the attached log for any insight.

I tried sending a video to demo but your uploader has a 200K restriction (recently changed)?

To add/edi/delete records from a database is the basic reason I would use Wappler so I MUST GET THIS TO WORK! Any help is appreciated by anyone.

report_2018-6-7_10-39-14.zip (223.9 KB)

Do you have the page somewhere live so we can check?

So your freezing problem is no more?

I presume you are also following exactly the Data Binding with Repeat Children and Dynamic Table creation as described here:


OK thanks for the quick look and response. I’ll revisit my work and see if your info gets me back on track.

To make the tabs display only the images and text related to each category, I’ve written five queries that sort by the first three letters of the image’s filename. Since I can use only one Server Connect, I plan on creating five separate pages as either includes or iframes and call them into the gallery page- one under each respective tab. This is the only way I can figure how to have the images display properly under the correct tab using a query. Is there a better way?

Not sure how this happened but the file


is corrupted and gives you javascript error so the rest of the page does not works.

Just delete it and save your page - so that a fresh one will be copied and uploaded.

Further more you are missing quote a few files just as well your data feed, so no data is available:

Too early to tell - but I’m working on it. :grinning:

OK Thanks. I’ll revisit my work and see if your info gets me back on track.

(Don’t see my reply so here it is again)

Here is my testsite: http://statecollegedev.com
Here are the test pages I’m working on to learn how to set up dynamic tables:

  • gallery-test1.html
  • gallery-test2.html

Maybe you didn’t see my reply as well so here it is again:

OK thanks. I deleted the existing and saved the page. I then re-uploaded the dmxAppConnect folder to my test site. Please run again to see if the errors no longer happen.

Still missing you data feed and have the corrupted file:

You know when publishing to the remote target - you can do it with a single click so everything get synchronized at once:


I never could get the onbaord FTP in Wappler to work. It checks out fine and the target is successful so I don’t know why this won’t work.

I’ve replaced the corrupted dmxConnect folder… Still have NO luck getting the table rows to display.

well seems the FTP is working just fine as now the files are uploaded (well except that you haven’t recreated the corrupted file)

But now you have a server error you in server connect action file:

So not sure what is missing there - maybe different database on the live server?

I used FileZilla to upload files - not Wappler’s internal FTP.

And OOOOPS… I did fail to update the dB on my hostsite - good catch for suggesting that. Please try again and see if things are now resolved.

Still trying to upload my 25.8MB vid but get the 2000000KB max size error.


Are you sure the video file is just 25mb? As the limit message states that the max is 200000kb=200mb