Docker missing mapping to the new NodeJS views

I switched to docker engine and I noticed the views folder is not accesible.

This volume is missing in the docker compose file. If views folder is going in root of course.

- '../../../views:/opt/node_app/views'

I didn’t want to report it as a bug as the functionality is not finished. So just in case you missed it @patrick

Thanks will check it out

1 Like

When running locally using node etc. everything works fine.
But when trying to do the same on a Docker target I get a 404 on the index.ejs page.
Fresh projects, everything vanilla

I also noticed, on the two projects i tried from scratch, that routing complained about not beeing able to create app/config/routes.json. Just created the config folder inside app and no more complaints

I am running other Wappler projects on Docker developement targets so my setup should be ok.
Routing problem on docker ?

Wappler 3 beta 4 on Catalina 10.15.5

Probably related to this. I don’t know if it was corrected in time.

Check your dockerfile in /.wappler/targets and add the line. Then just start your target again.

This was solved in previous beta’s