Cordova installation on Mac 10.15.3

I have this issue all over again when I re-opened a new project from yesterday.

I did a system check while online and I get the same “Cordova installing” hangup. Yesterday it showed that it installed all necessary files when I made the index.html file active in the code browser.

Today that doesn’t work.

2nd problem – I want to build a Desktop app for my Mac
I saw the 3 Platform icons – I clicked the Desktop since the Mac icon indicated ios mobile platform.

Looking at the online Wappler Desktop documentation – which is not a complete walkthrough that takes the user to the point of installing a local database connection – it indicated there is a PLATFORM TAB to be selected as well. I cannot get this Tab active and selectable while I am in the File browser view.

  1. online Wappler Desktop documentation indicates that Electron is to be installed. But what’s shown in the same Desktop instructions doesn’t match what I see – I am running the Pro version.

I don’t have the option to Install Electron.

  1. I want to get my Desktop application connected to my localhost MySQL database where I have tables waiting. I can’t add any actions until I’ve specified this but the usual methods are NOT available

When I look through Documentation I can’t find the in-depth setup for Desktop apps.

When I look through issues in the Forum I see even the most accomplished Wappler users reporting problems last year with this whole process – discussing fixes & installations of things I have already installed on my Mac laptop.

The Forum shows NO SOLUTIONS added to the discussions & NO “Solved”

What is the status now as we hit April Fools 2020?

Does Wappler need HELP to make this “easy” app?

Where can I find the Complete Wappler Tutorial that shows me things I must do that last year’s Tutorial is missing, please.

Hello, not sure what you mean by:


But the tutorial displaying detailed how to setup your project for building desktop apps is available at:

It guides you step by step what to do exactly.

From what i see, on your screenshot cordova is not installed and when the installation starts, it asks for your system password - why not enter it?

Also, what does “code browser” mean? What is code browser? Cordova installation has nothing to do with any file you open or any feature called “code browser”.

“code browser” – I gave a quick reference to being in the FILE BROWSER
and having Selected the “Code” tab I saw THE CODE of that file selected in the file browser –

Hundreds of html editors have used this exact term – “code browser”

Here is where I showed with a different screenshot that the Platform tab is greyed out – not available.

And I said the Tutorial I have read over and over does not Specify how the database connection is made for this — I am TOLD to make the database connection and to install Electron but these Tabs & Options are not Appearing in my Wappler.

I know how to make the connection in normal websites.

What I can do in Wappler for normal websites is NOT as your screenshot display.

You first need to install cordova, that’s where you issue is. Run a system check and enter your password where requested so cordova can be installed.
That’s why you don’t have the platform toolbar enabled …

Setup your site first, create simple html file, run it and worry about the database connections then.
Database connections with mobile or desktop apps work the same and this has been discussed many times here:


There is no way that I can enter the system password in the System checking window of Wappler

Why would the Project system check show all of the files installing and then completed yesterday in the same project & then not discover them the next day after I Saved All and Closed the Project yesterday.

Sorry that’s not quite possible :slight_smile:

Then please open a terminal window and enter:

sudo npm install cordova

this will install cordova for you. Restart Wappler and run the project again.

What is the recommended way to add dynamic data etc to a mobile app when you can’t add a Server Model to an App?

THAT question is the very question I was asking except I couldn’t find any mention of this in the Mobile App Tutorial you’ve referred to.

That piece of knowledge I consider ESSENTIAL to the “Creating Desktop Apps” NOT a WORD in it about “you can’t add a Server Model to an app” .
Only stating that it is set up the Same Way as any other website app.

Furthermore, NOT A WORD about HAVING TO SET UP 2 Projects to make one mobile or desktop app.

Again, ESSENTIAL steps to create a Desktop app are only referred to in a Forum string – these are issues that I must know about, but they are strung out in Forum questions which don’t show up when I try different searches.

Please check my last reply and install cordova so you can start using your desktop project.

At any rate, Teodor, you’ve spent your time with me very kindly and I very much appreciate it!

Thank you, thank you!

Please let me know if Cordova installs fine and if your system check shows everything is installed, after following my explanation.

terminal sudo does install cordova
when I supply my administrator credentials used when I installed my Mac laptop
but Wappler is not synched or served by the same installation, I assume from github?

Re-trying Wappler system check I was locked out after 3 tries with the same mac osX machine password

I’m assuming now, that although I was logged in and Wappler was open, that I must use the same password for Cordova installation as the one used to open my Wappler installation?

Github has nothing to do with your Cordova installation …

All i asked you was to:

  1. Install cordova using the sudo command using the terminal
  2. Quit Wappler, restart it.
  3. Do a system check.

Can you do exactly what i listed above and let me know of the results. Maybe you can try setting up a new desktop project as explained in the docs.

I have done exactly as you asked
That was my report

Now I have saved all, logged out then restarted the same project
And AGAIN, as I reported just now
The Cordova Wapper installation is held up for a password
It is evidently NOT the same password as the “sudo” Cordova installation that I just made

Can you setup a new desktop project and check what it does report there. If possible please share screenshot of the results in Wappler console.

It took several logouts & logins but I now have Cordova!

And I have my Platform tab enabled!

What finally worked was my system administrator login password, which had mysteriously failed on several previous attempts.

Thank you again, Teodor, for your kind professional support!

And this is the tutorial explaining how to use dynamic data with Desktop and Mobile Apps:

Nothing really complicated.


That is SUPPORT!

Thank you for this, Teodor! :+1: :+1: