Cookie is not set after sucessful login on mobile app

Wappler Version : Version 3.7.1 (3.7.1)
Operating System : macOS Catalina 10.15.7
Server Model: Nodejs
Hosting Type: Local docker

Hey community,

I need a rubber duck because I have a real issue to setup the login with wappler for my mobile app.

What have I done?:

  1. I have create two projects (1 nodejs, docker hosted, and one mobile (no kitchen sink template))

In the Node project I added:

  1. Security provider
  2. Setup CORS
    Screenshot 2021-01-17 at 09.53.54
  3. I have added 2 actions to the server: login and userDetails
  4. Created a login page to test the login in the nodejs environment (where the login works perfectly, the cookie get send and set)

In the mobile app:

  1. installed a new mobile project without the kichen sink template

  2. Added Framework7 and AppConnect local

  3. I added a login page like done for the nodejs app (e.g. server connect form)

  4. setup security policy in the head

  5. config.xml (the generatet one

What is the problem

Now when I submit my login form on the mobile app, the request goes successful through. See:

But what happens is that the cookie from the response is not set. See:

In the console I have only one error, but that is an authorization error down to the missing cookie :frowning_face:

Does anyone has an idea why the setCookie is not applied? And even better how do I solve this… it drives me nuts. :sob: I just want that login my mobile app.

I would also be glad about an example project where login form mobile against the nodejs server works. Then I could compare the setups myself.

1 Like

Try un-ticking Secure in the cookie options.

Hi @Dave thanks for you reply.

But apparently are these options only applied to the remember me token as @Teodor states in this post Security Provider Cookie Options.

I even tested to talk no bullshit but indeed it only applies to the remember me cookie. But even that cookie is not applied.

Did you try with the Secure option unchecked? Remember to clear any cache and temp files.


As I wrote I tried the option with unchecking the security option. I killed all docker service and reinstatntiated them since I am not sure how to archieve this Remember to clear any cache and temp files.

But even this made no difference. Only the remember me cookie seem to be affectted by this, since it removed the secure option from it when I inspecting it in the dev tools


Maybe its a Docker thing? We have only one documented issue in our little problems document for Android/Cookies with mobile and it was down to the Secure option… May be worth trying installing the Cookies Plugin for Cordova and see if that helps?

1 Like


I tried that but apparently it does not make any difference :(. Thanks for help though

1 Like

Test with the App Connect update posted here: Mobile App: Login successful but not retrieving identity