Connection credentials work in extension not wappler


#1

My database credentials work in server connect extension but not wappler… Getting invalid data source name error


#2

Hi @skirchuk,
Please when reporting issues be as detailed as possible. Be sure to provide what server technology are you using? What database are you using? When do you see the error?


#3

ok sorry … MySQL PHP … using localhost and have tried IP … it works fine in Dreamweaver with Server Connect extension … I open the page or try to recreate in Wappler and I get “invalid Data Source Name” when testing Connection … also using same ftp connection credentials which work in Wappler … thanks


#4

Check you have set the site server model to PHP, PHP connections don’t normally use a Data Source Names (DSN) but you will be offered the option in the dropdown if PHP is not specified


#5

PHP is selected as server model


#6

The question is still too vague. The impression that I get is that the remote connection works fine. Is the target set to a remote server when you get the error message?

image


#7

FTP connects to remote server but when I try to setup a database connection and hit the test button i get a data source name not valid error - I had to go back to using the server connect extension Dreamweaver where the exact credentials work. Also note that when I open the completed pages in wapple r after coding in Dreamweaver the connection still returns the error


#8

SOLVED !!! Hi I created a new target using the same credentials and it works … the target must have been corrupted for some reason