Code/Design view synchronization issues in v1.0.5

I am using a Macbook Pro 15", Intel Core i7, OS X 1.13.5

I have been having quite a few issues with the latest version of Wappler. When I attempt to save, the page either freezes or scrambles its elements. If I use the menu ‘Save’ item, the ‘Tab’ key or use the keys ‘CMD-S’ - the page reverts back to its prior condition or loses some elements. Cut & Paste from a external text document is a horror - things “fly” apart or corrupts the page.

When I click on an element, its properties either don’t display or it takes a long time to display. Often, “Styles” does not display the selected element’s newly created “ {}” rules when revisited or is VERY slow to apply them.

I’ve reinstalled v1.0.5 twice and the same issues re-occur. I think it is not handling caching properly. Is there a pList I can remove so Wappler can re-create it? I’ve lost three days of work messing with this and had to rebuild a site from scratch with flaky things constantly happening.

HELP! Any ideas/suggestions?

I have a similar issue, I thought I was the only one, so I stop complaining. Sometimes, the css file will just go empty…, or, when I apply a style to an element and go back to modify the style and safe, the style will disappear and element will have to be re-applied again…it takes time to build a standard application, i understand, I know we will overcome it all.

Hi Randy, sorry to hear about your troubles. This should normally never happen of course.

To track the issue, could you first send me the Wappler debug log, how to get it:

After that you can try to fully reinstall Wappler from scratch:

Added the error log.

Also followed your re-install instructions but the same issues occur. Possible that v1.0.5 runs flaky under OSX 10.13.5? Should I try running it under OSX 10.11?

Possible that v1.0.5 runs flaky under OSX 10.13.5?

Wappler seems to behave very erratically unders Windows 10 too. I haven’t tested recent versions very much so I can’t say for sure the problems started with the last update.

Choosing options becomes increasinly unreliable and breaks the code, some resulting in invavlid HTML. At this point selecting components, using the App Structure panel becomes unreliable with incorrect selections. Also, design view and code stop being in sync; items appear in design view but are not added in code view.

For example I spent a lot of time trying to find out how to make a modal slide down as it appeared, rather than just pop up. I pasted in the code from a sample on the DMX site and could see it worked alright in Wappler (having edited a few paths etc.). I could also see how simple it was to add this feature (I think perhaps it should be the default) - just a matter of selecting the ‘fade’ option. I had tried this before but it didn’t work. Now I knew what I was looking for I could see more clearly what Wappler was doing: sometimes it added the ‘modal’ class to the wrong div, sometimes it duplicated the first line of the modal div.

I think the problem could be do with caches. I closed Wappler, deleted the processes which are not stopped when the program closed and deleted hundreds of files stored here:
C:\Users\Tom\AppData\Local\Wappler\User Data\Default\Storage\ext\

After this, I could finally make a modal work as I wanted - just by clicking a checkbox. (Modal implementation is really well done - when it works reliably.)

Just to make this clear - are you working in code view or have you pasted some code in there, when things got out of sync?

Could you try to reproduce the issues - without using the code view - just the design view and the app structure and properties?

If that goes all ok - could you try reproducing the issues with using code view as you have done probably initially.

The only problem I can imaging is switching too often between design and code view and pasting and editing a lot of code in code view and then back and fort to design view or editors - then things can get out of sync.

@TomD - this isn’t related to any caches. You are juts doing a fresh start so everything is in sync.

If some views got our of sync - we have the refresh icons in their panels to sync them - but this is just to sync the view structures.

There shouldn’t be any code corruptions. So if you really got any - we would really appreciate if you could find the exact steps to reproduce otherwise it is really difficult for us to solve.

When reproducing try starting Wappler fresh and then also creating a new blank page and reproduce from there.

Yes, I do a lot of switching between code view and design view. Most of the issues happen while in design view. I very seldom have anything flaky happen while I’m working in code view and I do paste code from other sources - but these usually work fine. Its when I modify an element while in design view using one of the panels to make modifications (like dragging an element to another location in the App Structure panel and releasing it when the red arrow indicates its OK to do so.) This sometimes causes the app to freeze.

If I video capture my working in Wappler to reproduce what’s happening using a Macbook Pro and Movavi, how would I get this large file to you?

Yes seems we have some syncing issues when editing a lot in code view and going back to design view.
We have tracked them down and will fix it all in the next update.

For now when doing major changes in code view - make sure you save and also when going back to design view, hit the refresh icon in its toolbar. Or even better close and reopen the page.

We still haven’t tracked the issue of the minified bootstrap css code getting injected into the main html page.
This can definitely cause delays and freezing as it is huge code to load in code view. So if you can find out when this happen exactly it will be of a huge help @randyrie and @Bankym

Solved now in Wappler 1.1.0