Browser.goto Not Working When Route Contains Parameter

#1

Hi,

The following code is written on onsuccess of my server connect. Error on console says goto method not found.
The same goto method works fine if I set a route URL without parameter.

browser1.goto('./viewclient/{{serverconnect1.data.api1.data.Activity[0].client_id}}')

#2

try
browser1.goto(’./viewclient/’+{{serverconnect1.data.api1.data.Activity[0].client_id}}

#3

Did not work. Same error.

#4

Try taking out the curly braces, seen this issue before with dynamic parameters and browser component

1 Like
#5

Great! That worked.
browser1.goto('./viewclient/' + serverConnect1.data.api1.data.Activity[0].client_id)

But this needs to be fixed in the dynamic picker.

#6

Found the old post, @brad had the same problem back in November which is where i first came up with that solution (i found it by accident adding code manually).

#7

This is a really old bug. Should have been resolved then.

#8

Is this definitily a bug and not just the way the combination of static and dynamic data has to be entered in this situation?

I can’t remember if I’ve come across this or used it, but I would generally be concerned if changes are made to the way things like this work; there is always the possibility that changing syntax etc. will cause old code to break.

1 Like
#9

You make a valid point @TomD, retrospective changes can cause old sites to break. I think this could only be changed if it was possible for the old solution to also work. We have an easy solution now so it ain’t broke now, let’s not fix it

#10

The way this works is not the bug.
The bug is in the dynamic picker… which creates incorrect the final expression.

I don’t think the fix for this will affect the implementation @Hyperbytes has provided.
I have various other dynamic expressions built similarly either using dynamic picker or directly in code view.

The issue is isolated with browser.goto routing link picker.

1 Like
#11

I see - thanks for clarifying matters.

assigned patrick #12