Assets with no changes need updating

Wappler Version : 6.5.4
Operating System :
Server Model:
Database Type:
Hosting Type:

Expected behavior

Assets should only need to be updated once.

Actual behavior

These particular files keep coming back even after several attempts to update and commit to git. They appear as uncommitted changes, yet with comparison there are no differences.

1 Like

Same old problem.

This might be a newline issue

Windows uses \r\n, Linux uses \n

2 Likes

Might also be a timezone issue, does it still happen after a day?

Yes, been going on for a couple weeks

When does it exactly happen? After a Wappler update only or every time you open a project? Or after a git update / checkout or branch switch of the project?

Everytime the project is open...here is a screenshot I just grabbed:

1 Like

And then if you commit them to git? And recheck for assets updates?

Here is what the commit shows after committing today:

Screenshot 2024-05-15 at 2.54.20 PM

Which is similar to the commit a week ago on the same branch (no files in the commit):

Screenshot 2024-05-15 at 2.54.38 PM

And currently, the project assets show no updates needed.

I'll post back here if/when the assets show an update.

Might also be a permissions (chmod) issue

We need ls -lah command results to see the differences

As of now, all the files in /lib/modules, whether they are repeatedly updated or not, have the same permissions:

-rw-r--r--@

I can confirm same behavior on Windows 11.

update

Since Wappler's built in GIT management tool has some limitation - I'm using GIT for Desktop. And each time I'm switching in between branches - Wappler asking me to update almost ALL components even thought on GIT review - there are no changes at all.