Assets updater never clears after update on mobile project

Wappler Version : Beta 8
Operating System : mac
Server Model: none - mobile
Database Type:
Hosting Type:

Expected behavior

The assets updater should no continue to show once the update is applied to a mobile project

Actual behavior

It pops on every activation of a mobile project

How to reproduce

Click Update on the Assets Updater modal:

Files are copied:

But there are no changes in Git

Restart the project and repeat.

Could you check if this is still an issue, as I think we solved that a few updates ago.

Yep, checked again this morning and the issue remains.

My test:

Open MOBILE project.
Assets Updater has three updates (dmxBootbox5, dmxFormatter and dmxStateManagement)
Click Update
Commit to git
close wappler
Open wappler
Assets updater prompts for the same 3 items

found the problem, on mobile projects the assets updates had wrong root, so they were placed in the project root instead under www.

So should be solved now in the next Wappler update. You might want to cleanup those wrongly placed updates from the project root.

1 Like

Fixed in Wappler 5.1

This topic was automatically closed after 47 hours. New replies are no longer allowed.