API DATA SOURCE and Curl Requests

There are no transaction attempts in the dashboard. However, with the same config in the API schema, it works and I see the transaction in the dashboard.

@patrick - wappler uses stripe and so I’m guessing that wappler’s use of stripe implements wappler?
While while the wappler api might not handle such stripe requests out of the box, there must be a way? An encrypted key (to protect vars being passed to a server side script by anyone) is passed to a SSI script, which handles then the Stripe call via classic cURL means and gives the status in reply to wappler?

OK I see the problem you have.
You have to put the Stripe Authorization Bearer key within single quotes.

This is for all headers fields - if you don’t have dynamic values - always enclose them in single quotes.


So that should make it work :slight_smile:

Also I wonder why you use API Form as Forms are using for submitting data to the API and you are just fetching data so in that case API Data Source will do better.

1 Like

wonderful! Was also wondering about that. I’ll try out some APIs with these bearer tokens! Thanx so much.

1 Like

Well there you go:

1 Like

Yes yes that’s it. I am getting something now. Thanks much

I tried to connect to the API from Rossum.ai Invoice recognizionservice but not clear where to put autorization in wappler but get 404… via CURL , python no problem…

1 Like

Name : authorization
Value : ‘secret key’

tried it. still 405 method now allowed… confused now with api server side, client side and or api form/api action… I guess I need to use API Action and maybe thats why I get that 405 :thinking:

Header Name: Authorization
Header Value: secret_key poqMqDC...

I removed the first image of your post since it showed the whole secret key.